No components marked as affected
Resolved
The issue affecting payment, telehealth and, RxPhoto URL links has been resolved. All services are now functioning as expected.
Investigating
We’re aware that payment and telehealth URL links are not working as expected. Our team is investigating the issue and working to restore normal functionality.
We apologize for the disruption and will provide an update as soon as more information is available.